аукцион / FPR / donate / услуги / RSS / распечатать / вход 
Мой мир
Вконтакте
Одноклассники

Cisco HWIC-3G-GSM подключение к Tele2

[6 февраля 2020 | 10 февраля 2020 | 19 февраля 2020]

Недавно возникла необходимость подключить GSM-модем на ISR Cisco 1941. Подключение необходимо было всего на месяц, но возникли свои подводные камни при подключении. Практически все советы и примеры из Интернета не всегда срабатывали. Даже пинги не поднимались и часто видел комментарии к примерам о том, что в Cisco IOS 15 и выше этот модуль имеет проблемы и не будет функционировать как следует. Немного порывшись на официальном сайте Cisco и посмотрев примеры настройки модулей EHWIC-3G у меня получился конфиг совместимый с IOS 15 и Tele2.

И так, маленькое исследование, при установке модуля в слот и загрузке роутера у вас автоматически появятся следующие строки конфигурации:

chat-script gsm "" "atdt*98*1#" TIMEOUT 180 "CONNECT"
!
controller Cellular 0/1
!
interface Cellular0/1/0
 no ip address
 encapsulation ppp
 dialer in-band
 dialer string gsm
!
line 0/1/0
 script dialer gsm
 no exec
 rxspeed 7200000
 txspeed 384000

Как мы видим, роутер уже провёл какую-то первоначальную конфигурацию. От неё я и буду отталкиваться. Проблемы возникают в основном из-за того, что соединение отваливается по таймауту через 180 секунд. Это решается установкой сброса таймаута через dialer, но потом сброс соединения и уход в down происходит через пару часов и не поднимается. Для попытки удержания «вечного подключения» я воспользовался ip sla.

Я установил HWIC-модуль в первый EHWIC-слот. В итоге для настройки моего роутера необходимо совершить следующие настройки:

enable
cellular 0/1/0 gsm profile create 1 internet.tele2.ru

CONFIGUE TERMINAL

no chat-script gsm
chat-script gsm "" "ATDT*99*1#" TIMEOUT 180 "CONNECT"

dialer-list 1 protocol ip permit

interface Cellular 0/1/0
 ip address negotiated
 encapsulation ppp
 dialer in-band
 dialer string gsm
 ppp chap refuse
 ip nat outside
 no shutdown
 ppp ipcp dns request
 dialer idle-timeout 0
 dialer-group 1
 dialer idle-timeout 0
 async mode interactive
 exit

line 0/1/0
 exec-timeout 0 0
 exit

ip route 0.0.0.0 0.0.0.0 Cellular0/1/0

interface Gi0/0
 ip address 192.168.32.1 255.255.255.0
 ip nat inside
 exit

ip access-list standard NAT
 permit 192.168.32.0 0.0.0.255
 exit

ip nat inside source list NAT interface cell0/1/0 overload

ip sla 1
 icmp-echo 77.88.8.8 source-interface Cellular0/1/0
 threshold 1000
 timeout 1500
 frequency 5
 exit

ip sla schedule 1 life forever start-time now

Данная настройка привела к получению наиболее стабильного результата в Красноярске. Тонкость Tele2 заключается в том, что при подключении не требуется указывать логин и пароль. Настройка DHCP для вашей сети лежит уже на вашей совести, я же для тестирования использовал статические IP-адреса.

Если вас интересуют какие-либо подробности можете задавать вопросы. Пока у меня имеется данный модуль в наличии я готов ответить на ваши вопросы.

Тэги: ИТ, Cisco

Отредактировано:2020-09-04 13:26:33


Этот сайт использует файлы cookies, чтобы упростить вашу навигацию по сайту, предлагать только интересную информацию и упростить заполнение форм. Я предполагаю, что, если вы продолжаете использовать мой сайт, то вы согласны с использованием мной файлов cookies. Вы в любое время можете удалить и/или запретить их использование изменив настройки своего интернет-браузера.

Сообщайте мне о замеченных ошибках на: web@orcinus.ru. Все пожелания и советы будут учтены при дальнейшем проектировании сайта. Я готов сотрудничать со всеми желающими. В некоторых случаях, мнение автора может не совпадать с мнением автора! Phone: +7-902-924-70-49.

Top.Mail.Ru
Top.Mail.Ru LiveInternet Rambler's Top100 Яндекс.Метрика