Магазин / аукцион / FPR / donate / услуги / RSS / распечатать / вход 
Мой мир
Вконтакте
Одноклассники
Google+

[17 июня 2015 | 26 июня 2015 | 29 июня 2015]

Настройка Cisco 871 для работы с NAT

Недавно у знакомого возникла проблема с тем, что он приобрел Cisco 871, а в интернете все инструкции даются довольно странным образом, либо в командах опечатки, либо много пропусков. Ещё есть варианты с подключением циски к Билайну по L2TP протоколу. В нашем же случае всё очень просто.

И так, у нас есть сеть провайдера, который выдает нам IP-адрес по DHCP. И этот канал необходимо раздать клиентам в сети. Собственно, для упрощения администрирования адреса компьютеры будут получать со встроенного в циску DHCP.

Я приведу только выполняемые команды, те, что начинаются с восклицательного знака печатать не следует, они выполняют роль комментариев. И ещё, по умолчанию логин и пароль на циске это слова cisco. Так же необходимо заранее узнать у провайдера его DNS-сервера, так как внешний станет не доступен при проблеме со связью или если вдруг произойдёт финансовая блокировка.

!зададим имя пользователя и пароль для пользователя администратора
router> enable
router# conf t
router(config)# service password-encryption
router(config)# aaa new-model
router(config)# aaa authentication login default local
router(config)# username имя privilege 15 secret пароль

!включим доступ только по SSH
router(config)# hostname gw-border
gw-border(config)# ip domain-name orcinus.ru
gw-border(config)# crypto key generate rsa modulus 1024
gw-border(config)# ip ssh time-out 60
gw-border(config)# ip ssh authentication-retries 2
gw-border(config)# ip ssh version 2
gw-border(config)# line vty 0 4
gw-border(config-line)# transport input ssh
gw-border(config-line)# privilege level 15
gw-border(config-line)# exit

!включаем ускоренную коммутацию пакетов
gw-border(config)# ip cef

!временная зона GMT+7
gw-border(config)# clock timezone KRSK 7
gw-border(config)# exit
gw-border# clock set 17:20:00 19 Jun 2015

!обновление системных часов по NTP
gw-border# conf t
gw-border(config)# ntp server ntp1.vniiftri.ru
gw-border(config)# ntp server 129.6.15.28

!настройка DNS (адрес провайдера и Яндекс.ДНС)
gw-border(config)# ip domain-lookup
gw-border(config)# ip dns server
gw-border(config)# ip name-server 159.97.253 77.88.8.8 

!настроим IP-адрес на локальных портах в VLAN1
gw-border(config)# int Vlan1
gw-border(config-if)# ip address 192.168.1.1 255.255.255.0
gw-border(config-if)# exit

!настройка исключений DHCP сервера
gw-border(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.100
gw-border(config)# ip dhcp excluded-address 192.168.1.200 192.168.1.254

!настраиваем пул адресов DHCP
gw-border(config)# ip dhcp pool LAN
gw-border(dhcp-config)# network 192.168.1.0 255.255.255.0
gw-border(dhcp-config)# default-router 192.168.1.1

!отдаём DNS циски и Гугла
gw-border(dhcp-config)# dns-server 192.168.1.1 8.8.8.8
gw-border(dhcp-config)# import all
gw-border(dhcp-config)# domain-name orcinus.ru
gw-border(dhcp-config)# exit

!забираем адрес по DHCP от провайдера
gw-border(config)# int fa4
gw-border(config-if)# ip address dhcp
gw-border(config-if)# exit

!поднимаем WAN интерфейс
gw-border(config)# interface FastEthernet4
gw-border(config-subif)# no shutdown
gw-border(config-subif)# end

!включить нат на WAN
gw-border(config)# int FastEthernet4
gw-border(config-if)# ip nat outside
gw-border(config-if)# exit

!включаем нат на LAN
gw-border(config)# interface Vlan1
gw-border(config-if)# ip nat inside
gw-border(config-if)# exit

!включаем аццес-лист для описания правила выхода в интернет
gw-border(config)# ip access-list extended NAT
gw-border(config-ext-nacl)# permit ip 192.168.1.0 0.0.0.255 any
gw-border(config-ext-nacl)# exit

!включаем выход в интернет
gw-border(config)# ip nat inside source list NAT interface FastEthernet4 overload

удаляем ненужные сервисы и службы
gw-border(config)# no ip http server
gw-border(config)# no ip http secure-server
gw-border(config)# no service finger
gw-border(config)# no ip finger
gw-border(config)# no service tcp-small-servers
gw-border(config)# no service udp-small-servers

!записываем в память и перезагружаемся
gw-border(config)# exit
gw-border# wr mem
gw-border# reload

По факту сей опус памятка для себя в случае если кто-то из друзей опять возьмут себе данную железку. Эта статья никоим образом не является инструкцией для слепого копирования. Конфигурация сделана под мои вкусы и моё видение мелкой частной сети.

• Перейти в архив


Комментарии

Включите JavaScript для комментирования.


Этот сайт использует файлы cookies, чтобы упростить вашу навигацию по сайту, предлагать только интересную информацию и упростить заполнение форм. Я предполагаю, что, если вы продолжаете использовать мой сайт, то вы согласны с использованием мной файлов cookies. Вы в любое время можете удалить и/или запретить их использование изменив настройки своего интернет-браузера.

Сообщайте мне о замеченных ошибках на: web@orcinus.ru. Все пожелания и советы будут учтены при дальнейшем проектировании сайта. Я готов сотрудничать со всеми желающими. В некоторых случаях, мнение автора может не совпадать с мнением автора! Phone: +7-902-924-70-49.

Рейтинг@Mail.ru LiveInternet Rambler's Top100 Яндекс.Метрика