аукцион / FPR / donate / услуги / RSS / распечатать / вход 
Мой мир
Вконтакте
Одноклассники

[26 февраля 2020 | 13 марта 2020 | 20 марта 2020]

VLAN на Raspberry, проброс тегированого трафика с Cisco на Raspberry Pi

Недавно увидел забавную задачу. Знакомый админ хотел купить несколько USB-сетевых карт для подключения Raspberry к нескольким подсетям организации. Мне стало интересно работает ли Raspberry с VLAN, чтобы задействовать не несколько физических интерфейсов, а один физический и через него пробросить несколько виртуальных. Ведь Raspbian — это Debian, а в нём есть инструменты для работы с VLAN.

Как оказалось, всё работает исправно и решение проблем выглядит в виде нескольких строк кода в конфигах.

#NETWORK FILE /etc/network/interfaces
auto lo
 
iface lo inet loopback

# market
auto vlan10
iface vlan10 inet dhcp
   hwaddress ether 00:15:5d:11:11:24
   vlan-raw-device eth0

# aero1
auto vlan20
iface vlan20 inet static
   address 192.168.20.100
   netmask 255.255.255.0
   vlan-raw-device eth0

# aero2
auto vlan30
iface vlan30 inet static
   address 192.168.30.100
   netmask 255.255.255.0
   vlan-raw-device eth0

# saturn
auto vlan50
iface vlan50 inet dhcp
   hwaddress ether 00:15:5d:11:11:14
   vlan-raw-device eth0

wr mem

Вот таким образом мы добавляем эти порты на Малинке, со стороны свитча CISCO необходимо указать на нужном порту пробрасываемые VLAN.

interface FastEthernet0/24
 description LINK-TRUNK-RASPBERRY
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,50,1001-1005

Если Raspberry вставлен в порт роутера, то там немного изменяется синтаксис подключения:

interface GigabitEthernet0/0.10
 no shutdown
 encapsulation dot1Q 10
 description LAN-MARKET
 ip address 192.168.10.1 255.255.255.0

interface GigabitEthernet0/0.20
 no shutdown
 encapsulation dot1Q 20
 description LAN-AERO-1
 ip address 192.168.20.1 255.255.255.0

interface GigabitEthernet0/0.30
 no shutdown
 encapsulation dot1Q 30
 description LAN-AERO-2
 ip address 192.168.30.1 255.255.255.0

interface GigabitEthernet0/0.50
 no shutdown
 encapsulation dot1Q 50
 description LAN-SATURN
 ip address 192.168.50.1 255.255.255.0

wr mem

Кстати, похожий синтаксис, как на роутерах CISCO, так же поддерживается Raspberry. Так, например, можно изменить написание следующим образом:

#NETWORK FILE /etc/network/interfaces
auto lo
 
iface lo inet loopback

# market
auto eth0.10
iface eth0.10 inet dhcp
   hwaddress ether 00:15:5d:11:11:24
   vlan-raw-device eth0

# aero1
auto eth0.20
iface eth0.20 inet static
   address 192.168.20.100
   netmask 255.255.255.0
   vlan-raw-device eth0

# aero2
auto eth0.30
iface eth0.30 inet static
   address 192.168.30.100
   netmask 255.255.255.0
   vlan-raw-device eth0

# saturn
auto eth0.50
iface eth0.50 inet dhcp
   hwaddress ether 00:15:5d:11:11:14
   vlan-raw-device eth0

wr mem

Желаю вам успешных экспериментов и красивых решений.

Тэги: ИТ, Cisco, Raspberry

Отредактировано:2020-09-07 06:11:19




2 комментария
Имя: Алексей 🖉
да, у меня тоже завелось прямо из коробки.
Комментарий оставлен: 2020-03-13 00:00:00


Имя: Orcinus Orca 🖉
Алексей, это и должно было так заработать. Но не все начинающие сисадмины понимают как это работает. Само по себе решение занять несколько портов дорогостоящего оборудования вместо использования отработанной технологии меня немного коробит.
Комментарий оставлен: 2020-03-15 00:00:00



Этот сайт использует файлы cookies, чтобы упростить вашу навигацию по сайту, предлагать только интересную информацию и упростить заполнение форм. Я предполагаю, что, если вы продолжаете использовать мой сайт, то вы согласны с использованием мной файлов cookies. Вы в любое время можете удалить и/или запретить их использование изменив настройки своего интернет-браузера.

Сообщайте мне о замеченных ошибках на: web@orcinus.ru. Все пожелания и советы будут учтены при дальнейшем проектировании сайта. Я готов сотрудничать со всеми желающими. В некоторых случаях, мнение автора может не совпадать с мнением автора! Phone: +7-902-924-70-49.

Top.Mail.Ru
Top.Mail.Ru LiveInternet Rambler's Top100 Яндекс.Метрика