аукцион / FPR / donate / услуги / RSS / распечатать / вход 
Мой мир
Вконтакте
Одноклассники

Подключение Cisco по L2TP к сети Билайн

[5 февраля 2016 | 8 февраля 2016 | 16 февраля 2016]

При подключении к Билайну через L2TP через Cisco возникает серия проблем. Об этом пишет масса администраторов которые уже пытались это сделать. Но это возможно и вполне легко сделать. Перед настройкой роутера к работе, необходимо узнать ответы на несколько вопросов. Во-первых, нужно выяснить IP-адрес хоста tp.internet.beeline.ru. Во-вторых, нужно выяснить какой DNS-адрес выдаётся по DHCP от Билайна. В-третьих, нам нужны авторизационные данные: логин и пароль для подключения по L2TP.

L2TP.

Я покажу на примере Cisco 1841. Настроим интерфейс на подключение к сети и получение адреса по DHCP. Скорость порта и дуплекс в автоматическом режиме. Запретим определяться по цисковскому протоколу.

interface FastEthernet0/0
 mac-address 001a.4b6f.0101
 ip address dhcp
 no ip proxy-arp
 ip virtual-reassembly in
 load-interval 30
 duplex auto
 speed auto
 no cdp enable

Создадим класс L2TP для подключения.

l2tp-class beeline-l2tp-class

Далее необходимо создать псевдопорт и указать, что подключение производится через порт подключенный к сети Билайн.

pseudowire-class beeline-pseudowire-class
 encapsulation l2tpv2
 protocol l2tpv2 beeline-l2tp-class
 ip local interface FastEthernet0/0

Подготовка к созданию виртуального порта закончены, теперь можно запустить создание сетевого интерфейса. В место 0898XXXXXX нужно установить логин (совпадает с номером договора), а в место PassWORd необходимо установить пароль предоставленный провайдером. В место 10.10.3.251 нужно прописать IP-адрес tp.internet.beeline.ru.

interface Virtual-PPP1
 ip address negotiated
 ip mtu 1450
 ip nat outside
 ip virtual-reassembly in
 ip tcp adjust-mss 1400
 no peer neighbor-route
 ntp disable
 ppp chap hostname 0898XXXXXX
 ppp chap password PassWORd
 no cdp enable
 pseudowire 10.10.3.251 10 pw-class beeline-pseudowire-class

Далее прописываем роутинг всего траффика до виртуального интерфейса.

ip route 0.0.0.0 0.0.0.0 Virtual-PPP1
ip route 10.0.0.0 255.0.0.0 dhcp

Создаём правило для NAT и разрешаем всем выходить в интернет через виртуальный интерфейс.

ip nat inside source list 1 interface Virtual-PPP1 overload
access-list 1 permit 192.168.1.0 0.0.0.255

Всё, но на этом ещё не конец. Надо войти в виртуальный интерфейс и дать команду no shutdown. После этого появится сеть через L2TP.

Тэги: ИТ, Cisco

Отредактировано:2020-09-09 17:10:01


Этот сайт использует файлы cookies, чтобы упростить вашу навигацию по сайту, предлагать только интересную информацию и упростить заполнение форм. Я предполагаю, что, если вы продолжаете использовать мой сайт, то вы согласны с использованием мной файлов cookies. Вы в любое время можете удалить и/или запретить их использование изменив настройки своего интернет-браузера.

Сообщайте мне о замеченных ошибках на: web@orcinus.ru. Все пожелания и советы будут учтены при дальнейшем проектировании сайта. Я готов сотрудничать со всеми желающими. В некоторых случаях, мнение автора может не совпадать с мнением автора! Phone: +7-902-924-70-49.

Top.Mail.Ru
Top.Mail.Ru LiveInternet Rambler's Top100 Яндекс.Метрика